Incident has been resolved on Xledger side, all the invoices that arrived during the time when Xledger refused connection have been delivered to Xledger.
Posted Mar 17, 2025 - 11:52 CET
Investigating
We are seeing that there are login problems to Xledger for Propell Xledger File Transfer integration. We are investigating the root cause.
Posted Mar 17, 2025 - 08:42 CET
This incident affected: Propell Xledger File Transfer.