The queue has been cleared, new syncs are being completed in a timely manner.
Posted Jun 16, 2025 - 17:08 CEST
Monitoring
There was an issue in Propell Integration with handling of Master Data operations. All master data events triggered after 07:00 CET today have been accumulated into a queue which is currently being processed by the system. Currently syncs that have begun around 13:00 CET are still being processed.
Posted Jun 16, 2025 - 15:45 CEST
This incident affected: Propell.ai Integration Platform.