Issue with posting invoices for PowerOfficeGO V2 integration

Incident Report for Propell.ai

Resolved

The problem has been addressed and integration is back to proper service now.
Posted Jul 06, 2025 - 10:47 CEST

Identified

We have identified the root cause of the problem, and working on rectifying it.
Posted Jul 04, 2025 - 10:37 CEST

Investigating

We have observed an issue with posting invoices for PowerOfficeGO integration and are investigating the issue.
Posted Jul 04, 2025 - 07:25 CEST
This incident affected: PowerOffice GO.