Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2026 - 06:00 CEST
Scheduled
Propell Integration Platform will undergo infrastructure maintenance on Wednesday August 12th, from 6AM to 8AM CET time. No downtime is expected and users should not experience any noticeable service interruptions.
Posted Aug 10, 2026 - 16:03 CEST
This scheduled maintenance affected: Propell.ai Integration Platform.